• 加入浣熊技术会员上千VIP项目免费下载,所有资源均为站长付费收集,网站每天都会更新VIP资源,可以监督!

    1、本站课程每天都会更新发布,每月增加100个以上。

    2、本站为付费注册,注册邀请码,99元(即将上涨)。

    3、会员为永久会员,注册后,可免费下载全站所有资源,无需再次付费。

    4、所有资源都保存在百度网盘,方便您转存到自己的百度网盘。

    5、如果下载链接失效,请联系QQ 514246744

    6、注册时,请保存好自己的注册邀请码。

    7、如果在注册、使用过程中,遇到问题,请联系QQ 514246744

    8、点击注册会员

    购买后,显示的“卡密信息”就是注册邀请码

    注册会员,开启网赚之旅吧!

遇到简单的验证码,超少静态图片

原创 浣熊 6年前 (2016-12-18) 1647次浏览 已收录 扫描二维码

cs

今天遇到网站注册验证码,使用的是静态图片,而且是超级少的图片,图片总共就9张。broken heartbroken heartbroken heart

正好有空写了验证码识别。

w

把所以图片枚举,对应每张图片的验证码,就可以了

用易语言写了个简单的代码

代码:

.版本 2
.支持库 EThread
.支持库 internet
.支持库 spec

.程序集 窗口程序集_窗口1
.程序集变量 句柄q, 整数型

.子程序 _窗口1_创建完毕

测试 ()

.子程序 测试

启动线程 (&线程, , 句柄q)

.子程序 线程
.局部变量 图片地址, 文本型
.局部变量 n, 整数型
.局部变量 数组, 文本型, , "0"

数组 = { “0699”, “5568”, “6265”, “8643”, “7825”, “6412”, “0480”, “7663”, “0426” }
图片地址 = “http://www.xxxxx.com/front/images/x.png”(地址我就不透露了)
.计次循环首 (9, n)
    图片地址 = 文本替换 (图片地址, 38, 1, 到文本 (n))
    图片框1.图片 = HTTP读文件 (图片地址)
    编辑框1.内容 = 数组 [n]
    延迟 (1000)
.计次循环尾 ()
测试 ()

最终的效果就是gif,验证码识别成功

易语言源码 链接:http://pan.baidu.com/s/1c2xGOqG 密码:1oq4

仅供学习


浣熊技术 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明遇到简单的验证码,超少静态图片
喜欢 (0)
[]
分享 (0)